HOTAS Cougar Profile Problems

Discussions about Cockpits, Joysticks & Setups
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

HOTAS Cougar Profile Problems

Post by jerome833 » Thu Dec 09, 2010 4:33 am

Hi to everyone. I am new here just joined. I have a HOTAS Cougar with me but I am a complete noob in programming. I have downloaded a profile for Falcon 4.0 AF into my computer and have placed the relevant files into the correct locations. I can see it in the profiles page but when I select it, the buttons, axes do not respond as it should. I do not think it has anything to do with the stick because I can bind the buttons in the options page and they work. I have no idea what's wrong, any suggestions are greatly appreciated. Thanks!
User avatar
Lawndart
Virtual Thunderbird
Posts: 9123
Joined: Tue Mar 29, 2005 8:36 am
Location: Mooresville, NC

Post by Lawndart » Thu Dec 09, 2010 5:07 am

Did you download the profile to the device yet? You must download the .tmj file to the Cougar's memory first. This can be done in either Foxy (under one of the menus) or in the Cougar Control Panel (CCP). Just look for "Download to device..." on the right side.

Once done, in order to use the profile you also need "Button & Axis emulation ON" (otherwise the Kitty is just another DX input device).

This post may or may not be helpful too: HOTAS Cougar CCP setup
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

Post by jerome833 » Thu Dec 09, 2010 6:07 am

Thanks for the tip I did that, some of the buttons are responding as they should, but not all of them are responding as they should.
User avatar
Teej
Virtual Thunderbird
Posts: 1497
Joined: Fri Jul 31, 2009 9:29 pm
Location: Milwaukee, WI

Post by Teej » Thu Dec 09, 2010 8:36 am

Which profile did you use?

Some require some configuration within AF as well...Jagstang's profile, for example, you have to load a keymap file within AF.
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

Post by jerome833 » Thu Dec 09, 2010 8:47 am

I am using speedo_falcon_af profile.
User avatar
Lawndart
Virtual Thunderbird
Posts: 9123
Joined: Tue Mar 29, 2005 8:36 am
Location: Mooresville, NC

Post by Lawndart » Thu Dec 09, 2010 11:59 am

jerome833 wrote:Thanks for the tip I did that, some of the buttons are responding as they should, but not all of them are responding as they should.
Open Foxy and run the key tester. If each of your buttons produce the correct key response used in F4AF, then your joystick profile has loaded just fine and the issue must be that your keys aren't setup properly in F4AF.

You can also open CCP and click "viewer" at the bottom and make sure all your buttons/hat switches/axis light up properly when pressed (emulation should be OFF for this test). If yes, and you have your profile downloaded to the Cougar's memory and emulation is then turned ON before entering F4AF, the issue isn't the Cougar... at that point it would be (the key mappings) in F4AF.

Remember, when emulation is ON your joystick sends virtual keyboard commands (programmed in Foxy) so if you change any of the key mappings in game you'll have to update the Cougar programming as well (or just don't mess with the in game key mappings unless told to do so by whomever created the profile).
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

Post by jerome833 » Sat Dec 11, 2010 10:30 am

Thanks I'll try that when I go back on vacation now, will let you know if it works.
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

Post by jerome833 » Tue Dec 14, 2010 6:17 am

Hmm, I viewed the CCP viewer and realized after I installed the profile, when I depress the trigger, it activates the button beside the hat switch and a lot of the buttons are messed up too. Is it supposed to happen?
User avatar
Panther
Virtual Thunderbird
Posts: 997
Joined: Wed Sep 13, 2006 4:41 am
Location: Las Vegas, NV

Post by Panther » Tue Dec 14, 2010 1:56 pm

jerome833 wrote:Hmm, I viewed the CCP viewer and realized after I installed the profile, when I depress the trigger, it activates the button beside the hat switch and a lot of the buttons are messed up too. Is it supposed to happen?
No, that should not happen.
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

Post by jerome833 » Thu Dec 16, 2010 11:23 am

Ok, thanks so, is my Cougar screwed? Do I need to go change the Cougar or should I reset it? It all works fine without the profiles though, the key mappings are there. If it helps solve my problem, I am using Windows 7 64bit.
User avatar
Lawndart
Virtual Thunderbird
Posts: 9123
Joined: Tue Mar 29, 2005 8:36 am
Location: Mooresville, NC

Post by Lawndart » Thu Dec 16, 2010 3:10 pm

jerome833 wrote:It all works fine without the profiles though...
If everything works, meaning that all your buttons respond in the viewer/tester and all your axes respond properly as well without any profile active on the stick then it's not your hardware (i.e. your Cougar) that's the problem.

Just to be sure, do us a favor and open your CCP (Cougar Control Panel), click on "viewer" at the bottom, turn button & axis emulation OFF (color: red), and then move each axis back and forth to check that they respond properly. Push each button on the joystick and check that the corresponding button lights up in the "viewer".

Assuming all of the above checks out fine, it has to be either: 1) The profile you're using that has incorrect key commands programmed to begin with; 2) Key commands in AF that have been changed to something different than what the profile has them set to (either because you're not using default keys in AF, the person who made the profile didn't use default keys in AF but you are, or something to that affect); 3) The profile isn't downloaded and active (emulation has to be ON (color: green)), or; 4) A combination of all of the above, but definitely something software or emulation related between the programming and the list of key commands in game if everything checked out fine in the "viewer".
User avatar
Panther
Virtual Thunderbird
Posts: 997
Joined: Wed Sep 13, 2006 4:41 am
Location: Las Vegas, NV

Post by Panther » Thu Dec 16, 2010 3:21 pm

Can you share the link to the profile you downloaded for F4 Allied Force?
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

Post by jerome833 » Thu Dec 16, 2010 11:56 pm

I got it from http://cougar.flyfoxy.com/files.php the user who made it is Michael "Speedo" Crawford. When I switch off the emulation and go to the CCP all the buttons and axes work fine when the emulation is off.
User avatar
Panther
Virtual Thunderbird
Posts: 997
Joined: Wed Sep 13, 2006 4:41 am
Location: Las Vegas, NV

Post by Panther » Fri Dec 17, 2010 1:13 am

I haven't tried the profile yet but I'll try to test it tomorrow. However reading the instructions you did place the Speedo_Falcon_AF.key file in the C:\Program Files\Battlefield Operations\config folder? That is one very important file and the controller profile will not work without that file.
jerome833
Posts: 10
Joined: Thu Dec 09, 2010 4:24 am

Post by jerome833 » Fri Dec 17, 2010 11:25 am

Yeah I did.
Post Reply